Commit 4eee1a42 by Andreas Jaeger

Update requirements manually

The global requirments sync for this repo fails since it lists
packages that are not in the global list. Manually sync
requirements.

Failure log from requirements sync:
http://logs.openstack.org/d8/d89aad257d43fe02e42e44b2a0187dbd9f505c36/post/propose-update-requirements/15a7777/job-output.txt.gz#_2018-01-31_06_51_56_655451

Errors are:
'aniso8601' is not in global-requirements.txt or blacklist.txt
'click' is not in global-requirements.txt or blacklist.txt
'Flask-Cors' is not in global-requirements.txt or blacklist.txt
'itsdangerous' is not in global-requirements.txt or blacklist.txt
'MarkupSafe' is not in global-requirements.txt or blacklist.txt

Change-Id: I1cc19066f2127c37b7122e0068037d41f60fdaaf
parent bd831236
pbr>=1.6
# The order of packages is significant, because pip processes them in the order
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
pbr!=2.1.0,>=2.0.0 # Apache-2.0
aniso8601==1.2.0
click==6.6
Flask==0.11.1
Flask!=0.11,<1.0,>=0.10 # BSD
Flask-Cors==3.0.2
Flask-RESTful==0.3.5
Flask-RESTful>=0.3.5 # BSD
itsdangerous==0.24
jsonschema>=2.0.0,<3.0.0,!=2.5.0 # MIT
Jinja2==2.8
jsonschema<3.0.0,>=2.6.0 # MIT
Jinja2!=2.9.0,!=2.9.1,!=2.9.2,!=2.9.3,!=2.9.4,>=2.8 # BSD License (3 clause)
MarkupSafe==0.23
python-dateutil==2.5.3
pytz==2016.7
requests==2.11.1
six==1.10.0
gunicorn==19.6.0
python-dateutil>=2.4.2 # BSD
pytz>=2013.6 # MIT
requests>=2.14.2 # Apache-2.0
six>=1.10.0 # MIT
gunicorn>=19.0.0 # MIT
python-etcd>=0.4.3 # MIT License
oslo.utils>=3.20.0 # Apache-2.0
oslo.config>=3.22.0 # Apache-2.0
oslo.i18n>=2.1.0 # Apache-2.0
python-ironicclient>=1.11.0 # Apache-2.0
oslo.utils>=3.33.0 # Apache-2.0
oslo.config>=5.1.0 # Apache-2.0
oslo.i18n>=3.15.3 # Apache-2.0
python-ironicclient>=2.2.0 # Apache-2.0
python-keystoneclient>=3.8.0 # Apache-2.0
stevedore>=1.20.0 # Apache-2.0
sushy>=0.1.0 # Apache-2.0
......@@ -25,5 +25,5 @@ except ImportError:
pass
setuptools.setup(
setup_requires=['pbr'],
setup_requires=['pbr>=2.0.0'],
pbr=True)
......@@ -4,20 +4,20 @@
hacking!=0.13.0,<0.14,>=0.12.0 # Apache-2.0
coverage>=3.6
coverage!=4.4,>=4.0 # Apache-2.0
flake8-import-order==0.11 # LGPLv3
freezegun>=0.3.6 # Apache-2.0
python-subunit>=0.0.18
sphinx!=1.2.0,!=1.3b1,<1.3,>=1.1.2
oslosphinx>=2.5.0 # Apache-2.0
oslotest>=1.10.0 # Apache-2.0
testrepository>=0.0.18
testscenarios>=0.4
testtools>=1.4.0
freezegun>=0.3.6 # Apache-2.0
python-subunit>=1.0.0 # Apache-2.0/BSD
sphinx!=1.6.6,>=1.6.2 # BSD
oslosphinx>=4.7.0 # Apache-2.0
oslotest>=3.2.0 # Apache-2.0
testrepository>=0.0.18 # Apache-2.0/BSD
testscenarios>=0.4 # Apache-2.0/BSD
testtools>=2.2.0 # MIT
# releasenotes
reno>=1.6.2 # Apache2
reno>=2.5.0 # Apache-2.0
#api-ref
openstackdocstheme>=1.5.0 # Apache-2.0
openstackdocstheme>=1.18.1 # Apache-2.0
os-api-ref>=1.4.0 # Apache-2.0
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or sign in to comment